Govee Glides vs YeeLight W3 Bulbs

Just in case this can help anyone…
Over the past few days I have been having issues with my 4 YeeLight Bulbs (W3 multicolor) I have connected to LumiaStream (and have been connected since January with no issue).
2 of the bulbs failed connection about a week ago, then upon attempted reconnection of those bulbs 2 days ago the remaining 2 bulbs failed. Within the space I use the bulbs, I found there was no way to initiate a connection between the Yeelight app, the bulbs and my router. However, I could initiate a connection ONLY IF the bulbs were within extreme close proximity of the router, which was located in an adjoining room.
Prior to the bulbs failing I purchased a set of Govee Glide accent lights, which BTW I love.
As 2 of the bulbs were working with LumiaStream (and 2 were showing a static color) I never considered that the Govee lights were an issue, I simply figured the 2 bulbs required a reconnect. It wasn’t until I moved the Govee lights to a more permanent location within my space that I found out otherwise. While attempting reconnection over a dozen times of the 2…and then all 4 lights, I had left the Govee lights active. Once again never considering them to be an issue.
Today I decided to try to connect the YeeLights once again, this time with the Govee lights off. The reconnections occured with no issue. I then started LumiaStream and made certain the lights all functioned as they did previously. Once done I enabled the Govee lights and turned off the YeeLights and LumiaStream then alllowed the YeelIghts to reconnect to LS, which they did. Now all 4 YeeLights plus the Govee Glides work, albeit the Govees don’t work in LS.
The loss of connection issue did occur and could re-occur as I still plan to use the Glides. If this happens I will need to once again reset and reconnect the bulbs, which can ultimately prove a severe problem if it happens too often.
So if you have YeeLights (W3 variety) and decide to purchase Govee Glides, keep in mind that there could be an issue.

Although the Govee Glides seemed to be the issue 2 days ago, they are not as of yesterday. Even without the Govee’s connected, I can connect 2 and sometimes 3 Yeelight bulbs to my network (and therefore LS). However the 4th will not fulfill the connection process (app connection > fast blink and thats it). And if it does connect to my network, it only works within the Yeelight app and will not function outside of it (in Google Home or LS). In fact, sometimes when LS does its search for connected devices, it will initially display the 4 bulbs that had been connected previously but refreshes to sometimes list just 2 of the Yeelights, even when more are available. And if there is a 3rd bulb that seems to be working within LS, it will continue to do so regardless of not being on the list.
This whole Yeelight thing has been very disappointing.

Have you written to Yeelight support already? :slight_smile: We can’t help with their network problems, unfortunately.

I thought I responded to your comment. I guess not.
I have contacted them. To no avail.
I posted this here because my YeeLights are supported within LS and I’m sure many streamers may be interested in the Govee Glides at some point. I believed there may be a connection but as time passes it seems to not be the case, although that could change.
If it is an issue between the 2 manufacturers products, it could lead to issues for some users here.
If it is not and its an issue with YeeLights in general, that could also cause issues with some here.
Just wanted to bring my problem to the attention of anyone that may find it useful. If you feel that the post is unnecessary, please feel free to delete it.

Oh…don’t get me wrong :slight_smile: I didn’t want to argue or disagree. I just asked if you reached out :wink:

I just pointed out that these are not Lumia-related issues. It’s cheap hardware. I mean…there is a reason why Nanoleafs cost 200 Dollars and a Yeelight bulb 20 Dollar :wink:

I personally agree to you to 100% :slight_smile: And I don’t even complain about Govee :smiley:

1 Like

And so it goes. Last night I attempted to connect a 3rd YL bulb again. I got it connected and booted LS (which also performed an update) hoping to see all 3 lights under YeeLight Connections. All 3 showed for a second, then LS performed a new search and showed only one bulb. Strangely the 2 bulbs that were working in LS continued to work despite only 1 showing as connected under YeeLight > Connections. The 3rd bulb was never rediscovered by LS and only works in the YL app. I never bothered with the 4th bulb as that’s just never gonna work.
I wish it were simply 2 defective bulbs. I could live with that and have YL replace the 2 bad ones. Unfortunately it seems any 2 bulbs can work provided they are reset & connected first. And that makes it extremely frustrating.
I had a similar problem with 4 C by GE lights in my kitchen. For over a year they worked flawlessly with Google Home. Then one day they all started randomly dropping their connection at once. No amount of troubleshooting worked and despite there being many complaints about those bulbs I hoped it was my rental ISP router. So when I replaced it with my own the problem persisted so I just gave up and bought new bulbs that weren’t GE.
And you’re absolutely right. Spending more can often lead to better and less problematic hardware. And for my home lighting I use more expensive bulbs. But for streaming I figured saving a few bucks would be fine…and it was for awhile.

Did you try to give your Yeelight a static IP?

I did with the 3rd bulb thinking it might be an IP conflict. But that didn’t help at all. Still only connects and works within YeeLight app.
And for another twist, as I said in my last reply 2 bulbs do work in LS, but only one shows in the connections dialogue. Then if I open the YeeLight app, both working bulbs show as connected BUT the bulb that works in LS cannot be controlled at all in the YL app (can’t turn it on/off or change its colors).
None of this makes any sense. I would think if bulbs are defective they shouldn’t work at all in any app at any time.
I don’t know if the YeeLight model 1S works better. And Hue lights (even without needing the hub) are just so damn expensive although I know I probably won’t have the same issue.

You should check the logs of your router. Once I had an AP blocking Yeelight because it thought it was a DDoS attack as Yeelight phones all few seconds home. Could be that just your network locks them out.

Thought of that too but it doesn’t seem to the case. My logs actually show no connection or security issues at all since I first installed the router. Plus if it were, I would think the router security would stop all YeeLight app connections making it impossible to connect any bulbs at all.

No…the wifi network and the wired network are 2 separate things.

I don’t recall if you tried this already. Connect your Computer via Wifi and see if you find all bulbs :slight_smile:

The computer that controls LumiaStream is connected to WiFi.

I have only my 2 streaming PC’s on a Wired connection for stability.

Mmmhhh…that’s strange. Maybe try the router support. Most companies are trained today as smart stuff becomes common